'Precise Pangolin'에 해당되는 글 3건

  1. 2012.04.29 Ubuntu 12.04 에서 Eclipse 에 svn 설치하기....
  2. 2012.04.27 Ubuntu 12.04 LTS Release!!!!
  3. 2012.04.23 Ubuntu 11.10에 Adobe AIR 설치하기 (6)

필자는 구글 호스팅에서 SVN으로 프로젝트 소스들을 버전관리하고 있다.

해서 항상 Eclipse를 깔면 SVN을 설치하고 소스를 내려 받아 작업을 한다.

최근에 Ubuntu 12.04 LTS(The Precise Pangolin)에서는 한글 문제가 해결 되었다는 소식을 듣고

아직 Beta 2지만 바로 설치를 하였다.

그리고 Eclipse를 깔고 SVN을 설치 하였는데, Java HL Not Available이라고 나오며 Connector를 못찾아서

방법을 찾아 보니 시냅틱 패키지 관리자에서 subversion을 깔고 libsvn-java을 깔고나서

eclipse.ini에 -Djava.library.path=/usr/lib/jni 을 추가해도 계속적으로 Eclipse를 구동하면 lib를 못찾았다고 나오는 것이다.

그래서 찾아 보니 "libsvnjavahl-1.so"이녀석이 있어야 한다고 하는데 /usr/lib/jni폴더에는 엉뚱한 .so파일만 있지

정작 필요한 "libsvnjavahl-1.so"은 보이지 않는 것이다.


그래서 이 녀석이 어디있나 찾아 봤더니 바로 "/usr/lib/x86_64-linux-gnu/jni"에 있는 것이었다.

그래서 기존에 알려져있는 "/usr/lib/jni"에서 "/usr/lib/x86_64-linux-gnu/jni"을 바꿔서 eclipse.ini에 추가해주면 

아무 문제 없이 SVN이 구동되는 것을 환인했다.


기존 libsvnjavahl-1.so     위치 -Djava.library.path=/usr/lib/jni

변경된 libsvnjavahl-1.so 위치 -Djava.library.path=/usr/lib/x86_64-linux-gnu/jni


예! - 꼭 -vmargs 다음에 입력해 주세요!!!^^

-vmargs

-Djava.library.path=/usr/lib/x86_64-linux-gnu/jni

-Xverify:none

-Dosgi.requiredJavaVersion=1.6

-XX:+UseParallelGC

-XX:-UseConcMarkSweepGC

-XX:+AggressiveOpts

-Xms1024m

-Xmx1024m


아! 그리고 내 생각에 폴더명에 x86_64라고 쓰여있는 걸로 봐서 ia32-lib이 설치되어있어야 하는거 아닌가 생각하게 되었다.

Posted by gofly

댓글을 달아 주세요




우분투 12.04 LTS(Long Term Support)가 드디어 출시 되었습니다!!!!!!

한글 문제도 해결 되었고, 여러가지로 변경된게 많은데......;;;;;;

아직 깔아 보진 못했네요^^ 깔고나서 다시 한 번 글을 올리던 해야 곘네요....ㅋㅋㅋㅋ^^ㅋㅋㅋㅋ


아무튼 신난다 리눅스 쓰는 거!!!! ㅋㅋㅋㅋㅋ

Posted by gofly

댓글을 달아 주세요

Adobe Air
 
32bit 운영체계에서는 Terminal에서 아래와 같이하면 Adobe AIR 가설치됩니다.

wget 
http://airdownload.adobe.com/air/lin...RInstaller.bin 
chmod +x ./AdobeAIRInstaller.bin 
sudo ./AdobeAIRInstaller.bin 

만 약 64bit운영체계의 Ubuntu를 사용하고 있다면 아래와 같이 ia32-libs를 반드시 설치해줘야 합니다.

sudo apt-get install ia32-libs <-----중요
wget http://airdownload.adobe.com/air/lin...RInstaller.bin 
chmod +x ./AdobeAIRInstaller.bin 
sudo ./AdobeAIRInstaller.bin 

Access it through Applications → Accessories → Adobe Air Application Installer.






=================2012.04.22 추가========================
Ubuntu 12.04에서 Adoebe Air 설치시 주의 점!!!

12.04버전에는 Air를 설치할 때 Gnome Keyring 이나 KDE Wallet을 설치하라는 문구가 계속뜹니다.
문제는 Synap을 통해서 Gnome Keyring이나 KDE Wallet을 설치해도 Air 설치 도중에 계속 같은 문구가 뜬다는 점입니다.
해서 뒤지다 뒤지다 그 문구의 해결 책을 찾았네요^^ ㅋㅋㅋㅋ

링크파이을 만들어서 넣으면 되더군요......


32bit의 경우 


sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0

sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0


64bit의 경우


sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0

sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Posted by gofly

댓글을 달아 주세요

  1. 머니볼 2012.06.07 10:18  댓글주소  수정/삭제  댓글쓰기

    안되서 한참 헤맸는데.. 덕분에 잘 해결했습니다. 감사합니다

  2. 대박 2012.06.13 16:29  댓글주소  수정/삭제  댓글쓰기

    우와 님짱!!!

  3. 오오 2012.07.21 12:38  댓글주소  수정/삭제  댓글쓰기

    정말감사합니다 ㅎㅎ

  4. Favicon of http://twitter.com/gcd822 BlogIcon 한창엽 2013.08.30 17:46  댓글주소  수정/삭제  댓글쓰기

    오 잘되네요 감사하빈다^^